CVE-2026-34040GHSA-X744-4WPC-V9H2GO-2026-4887
Moby: AuthZ plugin bypass with oversized request body
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 29.3.1, 2.0.0-beta.8
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows attackers to bypass authorization plugins (AuthZ). This issue has been patched in version 29.3.1.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- moby moby
fixed in 29.3.1
- github.com/moby/mobyGo
fixed in 29.3.1
- github.com/moby/moby/v2Go
fixed in 2.0.0-beta.8
- github.com/docker/dockerGo
All versions
- github.com/moby/mobyGo
All versions