Skip to main content
← All vulnerabilities
CVE-2026-33674GHSA-283W-XF3Q-788V

PrestaShop: Improper Use of Validation Framework

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.2.5, 9.1.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 improperly use the validation framework. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • PrestaShop PrestaShop

    fixed in 8.2.5; From 9.0.0-alpha.1 · fixed in 9.1.0

  • prestashop/prestashopPackagist

    fixed in 8.2.5

  • prestashop/prestashopPackagist

    From 9.0.0-alpha.1 · fixed in 9.1.0

References 3

GitHub · PrestaShop/PrestaShop