Skip to main content
← All vulnerabilities
CVE-2026-33409GHSA-PFJ7-WV7C-22PRBIT-PARSE-2026-33409

Parse Server: Auth provider validation bypass on login via partial authData

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.6.52, 9.6.0-alpha.41
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • parse-community parse-server

    fixed in 8.6.52; From 9.0.0 · fixed in 9.6.0-alpha.41

  • parse-servernpm

    From 9.0.0 · fixed in 9.6.0-alpha.41

  • parse-servernpm

    fixed in 8.6.52

References 5

GitHub · parse-community/parse-server