Skip to main content
← All vulnerabilities
CVE-2026-32990GHSA-8MC5-53M5-3QJ2BIT-TOMCAT-2026-32990

Apache Tomcat: Fix for CVE-2025-66614 is incomplete

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.0.116, 10.1.53, 11.0.20
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Improper Input Validation vulnerability in Apache Tomcat due to an incomplete fix of CVE-2025-66614. This issue affects Apache Tomcat: from 11.0.15 through 11.0.19, from 10.1.50 through 10.1.52, from 9.0.113 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 11.0.15 · through 11.0.19; From 10.1.50 · through 10.1.52; From 9.0.113 · through 9.0.115

  • org.apache.tomcat:tomcat-coyoteMaven

    From 9.0.113 · fixed in 9.0.116

  • org.apache.tomcat:tomcat-coyoteMaven

    From 10.1.50 · fixed in 10.1.53

  • org.apache.tomcat:tomcat-coyoteMaven

    From 11.0.15 · fixed in 11.0.20

  • org.apache.tomcat:tomcatMaven

    From 9.0.113 · fixed in 9.0.116

  • org.apache.tomcat:tomcatMaven

    From 10.1.50 · fixed in 10.1.53

  • org.apache.tomcat:tomcatMaven

    From 11.0.15 · fixed in 11.0.20

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 9.0.113 · fixed in 9.0.116

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 10.1.50 · fixed in 10.1.53

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 11.0.15 · fixed in 11.0.20

References 1

lists.apache.org