Skip to main content
← All vulnerabilities
CVE-2026-32944GHSA-9XP9-J92R-P88VBIT-PARSE-2026-32944

Parse Server crash via deeply nested query condition operators

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.6.0-alpha.21, 8.6.45
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.21 and 8.6.45, an unauthenticated attacker can crash the Parse Server process by sending a single request with deeply nested query condition operators. This terminates the server and denies service to all connected clients. Starting in version 9.6.0-alpha.21 and 8.6.45, a depth limit for query condition operator nesting has been added via the `requestComplexity.queryDepth` server option. The option is disabled by default to avoid a breaking change. To mitigate, upgrade and set the option to a value appropriate for your app. No known workarounds are available.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • parse-community parse-server

    From 9.0.0 · fixed in 9.6.0-alpha.21; fixed in 8.6.45

  • parse-servernpm

    From 9.0.0 · fixed in 9.6.0-alpha.21

  • parse-servernpm

    fixed in 8.6.45

References 3

GitHub · parse-community/parse-server