Skip to main content
← All vulnerabilities
CVE-2026-32773PYSEC-2026-3966BIT-SPARK-2026-32773GHSA-9437-39HJ-3C93

Apache Spark: XSS Vulnerability in Spark Web 3.5.4

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 3.5.8
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.spark:*

    From 3.0.0 · fixed in 3.5.8

  • pysparkPyPI

    From 3.0.0 · fixed in 3.5.8

  • org.apache.spark:spark-core_2.12Maven

    From 3.0.0 · fixed in 3.5.8

  • org.apache.spark:spark-core_2.13Maven

    From 3.0.0 · fixed in 3.5.8

References 1

lists.apache.org