Skip to main content
← All vulnerabilities
CVE-2026-3240GHSA-45FJ-FVMM-XCC5

Concrete CMS below 9.4.8 is vulnerable to Stored XSS via Legacy form

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.4.8
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

In Concrete CMS below version 9.4.8, a user with permission to edit a page with element Legacy form can perform a stored XSS attack towards high-privilege accounts via the Question field. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 4.8 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N Thanks minhnn42, namdi and quanlna2 from VCSLab-Viettel Cyber Security for reporting.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Concrete CMS Concrete CMS

    From 5 · fixed in 9.4.8

  • concrete5/concrete5Packagist

    fixed in 9.4.8

References 2

GitHub · concretecms/concretecms

documentation.concretecms.org